The following system requirements are required for Virtual Surveyor:

  • Operating System: Minimum Windows 7 Service Pack 1, Windows 8, Windows 8.1 & Windows 10 (recommended)
  • Operating System Architecture: 64 bit
  • .NET 4.6 framework*

You get a good performance even on laptops or surface tablets.

* If it is not installed on your computer, Virtual Surveyor will install it for you during the installation process.